Follow

Hey Mastodon! Me and @krainboltgreene went over Mastodon 3.0's new features in this video, come watch:

youtube.com/watch?v=aYHYxOeQum

@Gargron @krainboltgreene I want to upgrade from 2.5.1 to the latest. It looks like I need to install 2.5.2, 2.6.0 and so on (restoring backups from 2.5.1 to latest did not go well when I tried that route). I hit a wall at 2.6.0.

~/live$ yarn install
yarn install v1.10.1
[1/6] Validating package.json...
[2/6] Resolving packages...
[3/6] Fetching packages...
error An unexpected error occurred: "registry.yarnpkg.com/flatmap-s: Request failed \"404 Not Found\""

How can I resolve this & update Mastodon?

@Gargron @krainboltgreene Here are the instructions I have been following: docs.joinmastodon.org/administ

I'd be happy to update them if they need updated.

If there are any efforts to make the upgrade process more standardized (e.g. same process every time from the sysadmin's point of view), I'd also volunteer to contribute there. I didn't see anything on the GitHub issues about any such efforts (nor anything about this error I am facing).

@Gargron @krainboltgreene It appears I have to go directly from 2.5.2 -> 2.6.4 and that all the versions in between are no longer able to be installed. There's no indication that it is safe to skip intermediate versions (where things like database schemas may have changed), but it **appears** that, at least in this upgrade path, everything is working. It would be good to include this in documentation on upgrading. I'll try to make a pull request that updates the documentation.

Sign in to participate in the conversation
Mastodon

Server run by the main developers of the project 🐘 It is not focused on any particular niche interest - everyone is welcome as long as you follow our code of conduct!