I'm happy to announce the release of !gnusocial 1.20.x :)

The minimum PHP version to run GNU social is now 7.0.0.

Major changes from previous release:

- Various patches on PEAR related components
- Various database related improvements
- Improved XMPP support
- Added Nodeinfo support (thanks @chimo)
- Various i18n and l10n bug fixes
- Improvements on Internal Session Handler (thanks @XRevan86)
- Improvements on OpenID support (thanks @tenma)
- Improved Media handling and safer upload (thanks @biodan)
- Redirect to previous page after login (thanks @tenma)
- Initial work on full conversion to PHP7
- Initial work on a better documentation
- Allow login with email (thanks @dansup)

More about it at https://notabug.org/diogo/gnu-social
cc: @mmn-o

Yeah... Are you GNUsocialists-devs willing to tell us more about what v1.20 brings us on our beloved chat tools? In terms of features...what do you mean by «Improved #XMPP support»

@diogo
@xrevan86 @tenma @biodan @chimo @mmn @dansup

@ingoberlab @diogo @xrevan86 @tenma @biodan @chimo @mmn @dansup

Is there any update in the way of economically supporting the development? Thx!!

Sign in to participate in the conversation
Mastodon

Server run by the main developers of the project 🐘 It is not focused on any particular niche interest - everyone is welcome as long as you follow our code of conduct!