While I was updating my Manjaro, I got :

> python-mistune1 and python-mistune are in conflict. Remove python-mistune?

Then I checked to see what is depending on python-mistune and it turned out that #jupyter depends on this python library. considering that both "python-mistune" and "python-mistune1" are in the community repo of #ArchLinux and both are Last Updated exactly on "2021-10-27 19:32 UTC" I wonder why David Runge has added a redundant library to the Arch community.

Any ideas fellows?

@mikapyon So just because of a less popular software (HyperKitty) we now have to mess around with the dependencies of a highly popular software (Jupyter )?

I wish there was a way that packagers could have communicate with the end user and to tell them why they have changed something.

To be clear, this issue of changing dependencies is not specific to Arch-based distros and not even to Linux distros, even in Doom Emacs the dependencies often changes and user is practically left with an error.

Follow

@Mehrad Even worse, if I understand correctly, the two packages can not co-exist as it is right now ε-(ーдー)

· · Web · 0 · 0 · 1
Sign in to participate in the conversation
Mastodon

Server run by the main developers of the project 🐘 It is not focused on any particular niche interest - everyone is welcome as long as you follow our code of conduct!