Follow

Toot! v1.11 has been released!

itunes.apple.com/us/app/toot/i

After a bit of a long break because of life and such, there is now a new version! This one brings - FINALLY - video and audio support! (Still missing play controls for these, but I figured I'd go ahead and release something, and get those in in the next version instead.)

For trying out the audio playing, I warmly recommend checking out ! I wanted to get this out in time for that month, so that's how late this ran...

Full release notes:

* Finally! Full support for video and audio posts!
* Bugfixes for saving and sharing attachments.
* You can now tap on image descriptions to hide them.
* Nicer transitions when opening attachments.
* There are now links to the bug tracker and official account on the settings screen.
* Fixed double tap to zoom.

Show thread

Toot! v1.11.1 is now also out.

itunes.apple.com/us/app/toot/i

This is a small bugfix release that fixes some new and old issues:

* Better reloading of timelines when posting and replies when replying.
* Fixed a bug that made music playing in the background stop while reading.
* Fixed a bug that made images sometimes not load on instances using Jortage.
* Fixed a bug that made images disappear on Pleroma instances.
* Fixed a small bug with zooming after dismissing image descriptions.

Show thread

@tootapp double tap zoom and audio! App now perfect. Every other update from now is just icing.

@tootapp we're sorry to be the bearer of bad news. but, only after tapping to dismiss an image description, pinch and spread to zoom the image no longer work (though double tap does still work then)

ios 12.2 on an SE, if it matters. we hate computers too

@alexis Fixed. It was only the area where the description used to be that didn't work, so it took me a while to figure out!

@tootapp hello, thank you for the update! Some things noticed:
1) There are no controls for video. Is it intended?
2) (was also before) whenever I make a reply, I don't see it in the current thread. Instead, I have to return to the timeline and tap on my message, getting back to that thread, but now with my comment visible.

@tootapp the visualizer is dope dude

Also neat song, what’s the title of the track?

@tootapp Very nice update! Will an option to hide the visualization and screen off playback be coming in future updates?

@tootapp I'm gonna be that guy: I'm really happy that this is still getting worked on and exists in the first place!

But I wouldn't mind custom emoji support on the app! :bowie_laugh:

@david You can use them by typing in the names directly. A picker will happen at some point hopefully.

@tootapp are there any plans for an android port? your app looks gorgeous

@nenmyx No, this app leans very heavily on iOS features and Swift.

@tootapp makes sense! hmm...i've been meaning to learn Android

@tootapp although my music getting paused every time I scroll past a video post is frustrating.

@tootapp fantastic! Thank you! I am getting a “server not correctly configured” error on cybre.space, is there some debug info I can send to the admins? Ive had this issue in the web UI too :/

@ticky Nothing other than what’s being show. That error doesn’t even sound like it comes from Toot though?

@tootapp I mean it’s definitely not toot specifically that’s broken, I’ve been trying to get this fixed for a while. I’m just wondering if you’ve got specific cases for showing that error in the app!

@ticky No, I don’t recall ever writing an error case like that. Is the error being sent from the server side maybe?

@tootapp maybe the “not correctly configured” is coming from the iOS media player api? Just thought it might be you given the “how annoying” haha

@ticky I think it must be. Maybe it’s something about certificates for https?

@tootapp I think the media server doesn’t support some chunking behaviour that iOS and macOS are demanding? It’s pretty frustrating.

@ticky @tootapp cybre.space recently changed CDNs, maybe that’s related?

@cinebox @tootapp maybe! It’s completely broken media playback on my iOS and macOS devices, including in the web UI

@ticky @cinebox @tootapp At least for me, clearing cache and reloading got the cybre web site working again. Still having trouble with GIFs but I'm 90% sure that's Safari's problem.

@ticky @cinebox Might want to check the CDN is sending the correct mime types. Had problems with that before.

@tootapp nothing stops you from going straight to version major 10!

@tootapp Nice! I had the music-in-background bug last night!

@tootapp for some reason it never shows a badge with unread count. Since like ever. Is that also fixed? Or am I the only one with that problem?

@tootapp Hrmpf. I’d much prefer a badge over getting all the notifications. But that’s my personal preference. I’d also like to see boosts and favs stacked instead of endlessly repeating the same toot in my notification list :)

@jwildeboer That is something Mastodon doesn't support on the server side, and doing it in the client is a bit challenging, but I would like it too. Just haven't had the time to try to see if I can figure it out.

@tootapp it’s IMHO a bit misleading to have the badge option in notification settings when it doesn’t do anything.

Sign in to participate in the conversation
Mastodon

Server run by the main developers of the project 🐘 It is not focused on any particular niche interest - everyone is welcome as long as you follow our code of conduct!